dS-NET peripherals

dScope Series III Operation Manual

dS-NET peripherals are not supported on all model numbers.

The dScope Series III supports control of peripheral devices connected via the 'dS–NET' connector on the dScope's rear panel. Up to 64 dS–NET devices can be daisy-chained on the dS–NET.

Details of how to install a chain of dS–NET peripherals is described in the About dS–NET section.

General configuration and control of dS-NET peripherals from the dScope application is covered in the dS-NET Peripherals Setup dialogue box section of the Operation Manual.

Currently-available dS–NET peripherals are:

I/O Switcher | A cascadable 16x2 relay switcher for analogue or AES3
VSIO Adapter | A versatile serial audio and control interface adapter
dS–NET peripherals


About dS-NET

Setting up a chain of dS–NET peripherals

Up to 64 dS–NET peripherals may be connected in a chain from the dScope's dS–NET connector. dS–NET peripherals must be differentiated by setting different addresses for each peripheral on DIP switches on the rear panels of the peripherals. Note that the DIP switches on the rear of the dScope itself are not involved in the dS–NET setup.

Generally, each peripheral has a bank of eight DIP switches, the right-hand six of which are used to set the dS–NET address. The remaining switches may have other functions. The six switches form a 6–bit binary word, with the MSB on the left, UP representing '0' and DOWN representing '1'. Peripherals are shipped with all switches UP, so the default address is zero. So for example, an address of 23 (decimal), 0x17 (hex), would be configured by setting the switches to UP, DOWN, UP, DOWN, DOWN, DOWN. Note that the two left-most DIP switches should be set to UP for normal operation, unless otherwise documented for a particular peripheral.

dS–NET connectors on the dScope and peripherals are 9–pin male dSub, with standard PC pinouts. The chaining of the dS–NET bus is by standard RS–232 'null-modem' cables. The dScope is connected to the first peripheral's left-hand connector ("From master or previous slave"). The peripheral's right-hand connector ("To next slave") is connected to the left-hand connector of the next slave, and so on. A suitable null-modem cable is supplied with each peripheral; extra cables can be obtained from Prism Sound or your local distributor, or can be obtained from a computer outlet.

For details of other connections to the peripherals, see the appropriate section in this manual.

dS–NET protocol

The dS–NET protocol is a system of commands and responses transacted on a standard RS–232 serial bus. However, it is not necessary for the dScope user to have any knowledge of this protocol; control of dS–NET peripherals is through the dScope's user interface and scripting / automation system, and the user is presented with a set of high-level, easy-to-use functions. Details can be found in the appropriate sections of the Operation Manual, and the dS–NET peripherals section of the Scripting Manual.

Firmware updates

Some dS–NET peripherals allow their firmware to be updated ('flashed') by the dScope software. This operation is described in the dS-NET Peripherals Setup dialogue box section of the Operation Manual.

Using dS–NET peripherals in non-dScope applications

Because dS–NET is based on a standard RS–232 layer, it is possible to use some dS–NET peripherals, for example the I/O Switcher, in non-dScope applications. Low-level details of the dS–NET protocol can be obtained from the Prism Sound website for this purpose. It is also intended to make available a Windows driver for dS–NET peripherals at a later date.

RS–485 operation

Although dS–NET is standardised on an RS–232 layer, it is also possible to operate it on an RS–485 instead, although for reasons of compatibility this is not recommended or supported.

To use dS–NET in RS–485 mode, it is necessary to:

· Change jumper settings in both the dScope and the peripherals
· Use different dS–NET cables with different pinouts;
· Fit a terminating plug to the right-hand ("To next slave") connector of the last peripheral in the chain;

For details, refer to Prism Sound and to the appropriate PCB jumper setting sections of this manual.

If problems are experienced with normal dS–NET operation, check that the jumper settings in the dScope and the peripherals are all in RS–232 mode.

About dS–NET dS-NET peripherals


I/O Switcher

This section describes the capabilities and operation of the I/O Switcher. For details of the layout of the unit and connector pinouts, see the I/O Switcher hardware layout section. For a description of the switching architecture, see the I/O Switcher architecture section. For information about controlling the I/O Switcher from dScope's dialogue boxes, see the Switcher Channel Array Control dialogue box and I/O Switcher Diagnostic Control dialogue box sections of the Operation Manual. For VBScript programming information, see the dS–NET peripherals section of the Scripting Manual.

Overview

The I/O Switcher is a dS–NET device, primarily intended for use with the dScope Series III test and measurement system. It is a serially-controlled 16-into-2 relay switcher, which can be used for switching either analogue or digital (AES3) audio signals.

Additional features

As well as providing the basic 16-into-2 switching matrix, the I/O Switcher has three additional functions:

· Balance-test mode: each Bus can be switched into 'balance-test' mode, a special mode used in the input switching configuration, for measuring the output balance of the EUT.

· Load switching: each bus can be connected to a load applied to a pair of 4mm sockets on the rear of the I/O Switcher. This is useful for power amplifier testing.

· DC measurement: the DC voltage on each leg of each bus can be read, in 1V steps, over the range+/-128V. This is primarily intended for checking phantom power sourcing from inputs under test.

Connections

The two 'Bus' connections are each provided on both male and female XLR connectors, allowing each to be used as either an 'input switcher' (to drive dScope's analyzer inputs from a selection of many EUT outputs) or an 'output switcher' (to drive a selection of EUT inputs from the dScope's generator outputs).

Many I/O Switchers can be cascaded together to make larger input or output switching matrices by connecting the second XLR connector to a daisy-chain of I/O Switchers. Alternatively, one of the I/O Switcher's buses can be used as an 8-into-1 input switcher and the other as a 1-into-8 output switcher.

The 16 'channel' connections are provided as two 'Groups' of eight channels, each group on a 25–way female dSub connector. Breakout cables to XLRs (male for output switching and female for input switching) are available from Prism Sound, alternatively the operator can construct his own cable to suit the EUT. This configuration allows the I/O Switcher to serve as both input and output switcher without modification, since there is no need to fit differently-sexed channel XLRs.

For user's who don't wish to assemble their own cable looms for the I/O Switcher, a number of alternative accessories are available to connect the I/O Switcher's Group connectors:

· Group connector to eight male XLRs (for professional analogue or digital input switchers);
· Group connector to eight female XLRs (for professional analogue or digital output switchers);
· Group connector to eight RCA/phonos (for consumer analogue or digital input or output switchers);
· Four Group connectors to 19" 2U patchfield with 20 male XLRs (four unconnected) and 20 female XLRs (four unconnected) for professional I/O switching;

Serial control

The I/O Switcher's serial control port follows the dS–NET standard, based on the RS–232 protocol. Up to 64 dS–NET devices can be daisy-chained from the dScope's dS–NET connector using special dS–NET cables. dS–NET devices are differentiated by setting different addresses for each on rear-panel DIP switches. Details of how to configure a chain of dS–NET peripherals are in the About dS-NET section.

dS–NET devices are easily controlled from their dedicated dialogue boxes in the dScope software, or from a VBScript. In the case of the I/O Switcher, no complex binary manipulations or sequences are required; the desired channels can be simply selected in a single operation. If multiple switchers are connected to form large arrays, these can be described at the head of the script, allowing the whole array to be addressed as if it were a single switcher. Details of how to control the I/O Switcher from a VBScript can be found in the dS–NET peripherals section of the Scripting Manual.

I/O Switcher dS-NET peripherals


Hardware layout

The I/O Switcher front panel contains the XLR connectors for the A and B Buses, the 37–pin dSub connectors for the channel Groups, and a number of indicators which display the state of the switcher. Pinouts of the XLR and dSub connectors are detailed below.

The rear panel contains the IEC mains inlet (with integral switch, fuse and voltage selector), dS–NET connectors for serial control, the address DIP switches, and two pairs of 4mm load connectors for the A and B Buses. The About dS–NET section contains instructions for interconnecting the dS–NET cables and setting the address DIP switches.

The I/O Switcher is supplied with removable 19" racking ears, which may be removed for table-top operation. For table-top operation, it is fitted with removable plastic feet which may be removed for rack operation.

Changing the mains voltage or fuse

The I/O Switcher's mains inlet is of the same type as the inlet of the dScope itself. For instructions on changing the mains voltage or fuse, see the Changing the mains voltage or fuse page in the Hardware section.

Front panel indicators

The 'On' indicator is lit red when the unit is powered in 'Standby', and green when the unit is operating and has been initialised by dS–NET.

The 'Com' indicator flashes when the switcher is processing a dS–NET command.

32 green LEDs indicate the state of the main switching matrix. The left-hand bank show Group X crosspoints, the right-hand bank Group Y. The upper row show connections to Bus A, the lower row to Bus B. LEDs are lit to indicate that a crosspoint is closed.

The 'Load' LEDs are lit to indicate that the load-switching relay for that Bus is closed.

The 'Bal' LEDs are lit to indicate that the Bus is in 'balance-test' mode.

Connector pinouts

The following table shows the pinout of the Group connector (37–way dSub):

Channel | + (hot) | – (cold) | Signal Gnd
1 | 36 | 17 | 18
2 | 34 | 15 | 16
3 | 32 | 13 | 14
4 | 30 | 11 | 12
5 | 28 | 9 | 10
6 | 26 | 7 | 8
7 | 24 | 5 | 6
8 | 22 | 3 | 4
Pins 2,21,23,25,27,29,31,33,35 & 37are extra signal gnds
Pins 1, 19 and 20 have no connection

The Bus XLRs are wired conventionally, i.e. Pin 2: hot, pin 3: cold, pin 1: signal ground.

I/O Switcher hardware layout I/O Switcher


Architecture

The figure below shows the architecture of the I/O Switcher.

The crosspoint switching is organised with two Buses ('A' and 'B') and two eight-channel Groups ('X' and 'Y'). Together these form a 16x2 switching matrix. All inputs and outputs are two-leg balanced connections, although the – (cold) legs can be jumpered to signal ground for unbalanced operation if required. The crosspoint relays can carry a maximum current of 2A, and switch a maximum voltage of 250V. Note that repeated switching at high currents is likely to damage the relay contacts.

The DC voltage between each leg of each bus and signal ground can be measured by an on-board A/D converter. The range is +/-128VDC, and the resolution is nominally in 1V steps. This feature is mainly used for testing phantom power voltages supplied by inputs under test.

In the case of an input switcher, each Bus may be switched into 'balance-test' mode for measuring the output balance of equipment under test. In this mode, the Bus output is taken between signal ground and the centre tap of a 600R resistor connected between the two legs of the selected input. The resistor is composed of two 0.01% matched halves in order that the balance of the resistors is unlikely to dominate the output balance of the equipment under test. The dScope's analyzer input impedance should be set to 600R in order to enact the standard method of balance measurement. A maximum signal amplitude of 28dBu (19.45Vrms) can be tolerated by the balance-test circuit; beyond this, the resistors may be damaged.

A load can be applied between the two legs of each Bus, which is connected via a pair of 4mm ('banana') sockets on the rear of the unit. The maximum load current is 12A if the switcher is only connecting the load to the XLR connector of the Bus, i.e. if the load current does not flow through the switching matrix. If the load is applied to a Group channel via the switching matrix, the maximum matrix current of 2A must not be exceeded. A fuse is included to protect the switching matrix from excessive currents.

I/O Switcher architecture I/O Switcher


PCB jumper options

TO PREVENT SHOCK HAZARD, THE I/O SWITCHER SHOULD ONLY BE OPENED BY QUALIFIED PERSONNEL. REMOVE THE POWER LEAD FROM THE I/O SWITCHER BEFORE REMOVING THE TOP COVER.

A number of I/O Switcher options are available through PCB jumpers. These are:

Disconnection of signal ground from chassis

Configuring unbalanced operation

Switching the dS–NET interface from RS–232 to RS–485

The top cover of the I/O Switcher must be removed to access the PCB, which is shown in the diagram below. Jumpers should be removed, fitted or relocated using small snipe-nosed pliers. Removed jumpers should be carefully retained for future use.

The jumpers in the diagram are shown in the default positions.

Disconnection of signal ground from chassis

The signal ground connections on the Group and Bus connectors are connected to a signal ground plane on the PCB. Normally, this signal ground is also connected to the chassis of the I/O Switcher and hence to mains earth. It is possible to disconnect signal ground from chassis by relocating two jumpers. This should not normally be necessary, and is discouraged since the connection of signal ground to mains safety earth can help to prevent an electric shock hazard in some situations.

Jumper | Chassis (default) | Isolated
LK3 | 1-2 | 2-3
LK9 | 1-2 | 2-3

Configuring unbalanced operation

The I/O Switcher can switch unbalanced signals as well as balanced, and normally no change to the switcher is necessary. However, to simplify interconnection wiring for some unbalanced equipment, it is possible to configure the I/O Switcher so that the inverted (-) leg of each Bus is connected to signal ground. Note that accidental connection of some types of balanced equipment to the I/O Switcher in this mode can cause damage to the equipment or to the I/O Switcher, since inverted outputs may drive a short circuit to signal ground.

Jumper | Balanced (default) | Unbalanced
LK5 (A Bus) | 2-3 | 1-2
LK6 (B Bus) | 2-3 | 1-2

Switching the dS–NET interface from RS-232 to RS-485

Although dS–NET is standardised on an RS–232 layer, it is also possible to operate it on an RS–485 instead, although for reasons of compatibility this is not recommended or supported.

Jumper | RS–232 (default) | RS–485
LK12 (all four jumpers) | Towards dSub | Away from dSub
LK13 (all four jumpers) | Towards dSub | Away from dSub
LK2 | Towards dSub | Away from dSub

Note that in RS–485 mode, different dS–NET cables must be used, and the last dS–NET peripheral must be fitted with a termination. For more details, see the About dS–NET section.

The dScope software has no knowledge of whether RS–232 or RS–485 mode is selected.

I/O Switcher PCB jumper options I/O Switcher


Fuses and ratings

TO PREVENT SHOCK HAZARD, THE I/O SWITCHER SHOULD ONLY BE OPENED BY QUALIFIED PERSONNEL. REMOVE THE POWER LEAD FROM THE I/O SWITCHER BEFORE REMOVING THE TOP COVER.

Fuse locations and ratings are as follows:

FUNCTION | LOCATION | TYPE
Mains | Mains inlet IEC block (external) | 1A(T) 20mm, CER
Power supply output | Main board, F1 (internal) | 1A(T) 20mm, GLS
Bus A protection | Main board, F2 (internal) | 2A(T) 20mm, GLS
Bus B protection | Main board, F3 (internal) | 2A(T) 20mm, GLS

Note that the locations of internal fuses are shown in the PCB diagram in the I/O Switcher PCB jumper options section.

The I/O Switcher's mains inlet is of the same type as the inlet of the dScope itself. For instructions on changing the mains voltage or fuse, see the Changing the mains voltage or fuse page in the Hardware section of the Operation Manual.

I/O Switcher fuses and ratings I/O Switcher


Specifications

Physical
Dimensions: 485x245x44mm (including rack mounting ears)
Weight: 2.2kg
Mains voltage: 90..125VAC/180..250VAC switchable
Power consumption: 15W
Operating temperature: 0 to 40ºC, max 85% relative humidity

Switching
Crosspoint switch initial resistance: <0.5R per leg
Bus to load connector initial resistance: <0.2R per leg
Channel-to-channel cross-talk: <–140dB, 20Hz to 15kHz
Measured on either bus, routed from any channel, with any other channel carrying hostile signal to other bus, 50R source impedance, 100kR load impedance, balanced or unbalanced operation.
All-channels cross-talk: <–135dB, 20Hz to 15kHz
Measured on either bus, routed from any channel, with all other channels carrying hostile signal to other bus, 50R source impedance, 100kR load impedance, balanced or unbalanced operation.

Maximum ratings
Crosspoint switching voltage: 250V
Crosspoint switching current: 2A
Note that repeated switching of high currents will damage the relay contacts and increase switch resistance. It is not recommended that the crosspoint relays be subjected to currents beyond 100mA or switched loads above 5W if specified switch resistance is to be maintained.
Load current: 12A (2A through crosspoint)
Balance-test amplitude: 28dBu (19.45V RMS)

I/O Switcher specifications I/O Switcher


VSIO Adapter

This section describes the capabilities and operation of the VSIO (Versatile Serial I/O) Adapter. For details of the layout of the unit and connector pinouts, see the VSIO hardware layout section. For a description of the audio and control architecture, see the VSIO architecture section. For information about controlling the VSIO from dScope's dialogue boxes, see the VSIO Control dialogue box section of the Operation Manual. For VBScript programming information, see the dS–NET peripherals section of the Scripting Manual.

Overview

The VSIO Adapter is a dS–NET device primarily intended for use with the dScope Series III test and measurement system. It is an interface adapter which allows bi-directional translation between the dScope's AES3 output and input, and serial audio multiplex interfaces (for example I2S) such as are commonly found on digital audio ICs. The exact timing arrangements of the serial multiplex and its electrical properties (such as rail voltage) can be freely adjusted by the user.

The VSIO Adapter can transact up to 16 multiplexed channels on a single wire, or up to eight on each of two wires, or up to four on each of four wires. Each VSIO output 'slot' (channel) can be driven from the dScope Signal Generator's A or B channel, or can be muted; any two VSIO input slots (channels) can be routed to the dScope's Signal Analyzer. Audio wordlengths between 8 and 24 bits can be positioned anywhere within a slot length of 8, 16, 24 or 32 bits; data can be transacted MSB- or LSB-first. Clock polarities and multipliers can be freely selected; frame clocks can be generated one-bit-early or single-bit-width if required; sign extension is supported. Synchronisation can be from the dScope of from the EUT (either SCK/LRCK or MCK), and EUT rail voltages of 1.8V, 2.5V, 3.3V or 5V (TTL or CMOS threshold) are supported.

Additional features

As well as carrying out the audio transcoding function, the VSIO also provides a versatile I2C / SPI control port which can be used to control component-level devices on the EUT during testing.

Connections

The VSIO Adapter is connected to the dScope with two AES3 (XLR) cables, one for the Generator and one for the Analyzer. If the EUT is to be the clock master for the Generator, an additional AES11 (XLR) cable is required for the dScope's Digital Output Reference Sync input. Three short XLR cables are therefore supplied.

Short (20cm) breakout cables are supplied for connecting the Generator and Analyzer serial audio multiplexes and the control port of the VSIO Adapter to the EUT. These are terminated in in-line sockets for 0.025" square PCB posts, although spring 'hooks' are also provided to clip to IC legs etc. 1m "twist'n'flat"extension cables are also provided which should generally be fitted between the VSIO Adapter ports and the breakout cables. For further information about cabling and termination issues, see the relevant section of the PCB jumper options section.

Serial control

The VSIO Adapter is controlled by the dScope using the dS–NET standard, based on the RS–232 protocol. Up to 64 dS–NET devices can be daisy-chained from the dScope's dS–NET connector using special dS–NET cables. dS–NET devices are differentiated by setting different addresses for each on rear-panel DIP switches. Details of how to configure a chain of dS–NET peripherals are in the About dS-NET section.

dS–NET devices are easily controlled from their dedicated dialogue boxes in the dScope software, or from a VBScript. The VSIO Adapter is configured and controlled using the dS-NET Setup and VSIO Control dialogue boxes. Details of how to control the VSIO Adapter from a VBScript can be found in the dS–NET peripherals section of the Scripting Manual.

VSIO Adapter dS-NET peripherals


Hardware layout

The VSIO Adapter front panel contains the XLR connectors for connection to the dScope's Digital Input, Digital Output and Digital Output Ref Sync connectors, as well as loop-through XLRs for each. The loop-through connectors can bypass the VSIO Adapter under software control from the dScope so that normal operation of the dScope's DO, DI and REF connections is possible without replugging. The panel also contains two 15-pin dSubs to connect the Generator and Analyzer audio data and clocks to/from the EUT, a 9-pin dSub connector for the I2C / SPI EUT control port, and a number of indicators which display the state of the VSIO Adapter. Pinouts of the XLR and dSub connectors are detailed below.

The rear panel contains the IEC mains inlet (with integral switch, fuse and voltage selector), dS–NET connectors for serial control from the dScope, and the address DIP switches. The About dS–NET section contains instructions for interconnecting the dS–NET cables and setting the address DIP switches.

The VSIO Adapter is supplied with removable 19" racking ears, which may be removed for table-top operation. For table-top operation, it is fitted with removable plastic feet which may be removed for rack operation.

Changing the mains voltage or fuse

The VSIO Adapter's mains inlet is of the same type as the inlet of the dScope itself. For instructions on changing the mains voltage or fuse, see the Changing the mains voltage or fuse page in the Hardware section.

Front panel indicators

The 'On' indicator is lit red when the unit is powered in 'Standby', and green when the unit is operating and has been initialised by dS–NET.

The 'Com' indicator flashes when the unit is processing a dS–NET command.

The 'EUT Clk Master' indicators are active for the Generator and Analyzer paths when that path is configured to be synchronized to the EUT (in either LRCK/SCK or MCK modes). The indicator is lit to indicate that the VSIO Adapter is successfully locked to the EUT, or flashes if successful lock cannot be achieved.

The voltage indicators are lit whenever the VSIO Adapter's audio and control ports are powered, and indicate the operating voltage.

For more information see the VSIO Adapter Control dialogue box section in the Operation Manual.

Connector pinouts

The following table shows the pinout of the serial audio port connectors (15–way dSub). Note that the four data wires are outputs on the "Generator (to EUT)" connector and inputs on the "Analyzer (from EUT)" connector. The directions of the clock signals (as well as their timings) can be programmed by the user; for more information see the VSIO Adapter Control dialogue box and VSIO Adapter Architecture sections.

Signal | Ground | Name | Direction | Description
1 | 9 | DATA1 | O(G), I(A) | Data Wire 1
2 | 10 | DATA2 | O(G), I(A) | Data Wire 2
3 | 11 | DATA3 | O(G), I(A) | Data Wire 3
4 | 12 | DATA4 | O(G), I(A) | Data Wire 4
5 | 13 | LRCK | I/O | Frame Clock
6 | 14 | SCK | I/O | Serial (Bit) Clock
7 | 15 | MCK | I/O | Master Clock
8 | - | - | - | No connection

The following table shows the pinout of the control port connector (9–way dSub). Note that the port can be configured to work as either an SPI ('3-wire') port or an I2C ('2-wire') port. For more information see the VSIO Adapter Control dialogue box and VSIO Adapter Architecture sections.

Signal | Ground | Name | Direction | Description
1 | 6 | CLK | I/O | SPI Clock / I2C SCL
2 | 7 | DIN | I/O | SPI Data In / I2C SDA
3 | 8 | DOUT | O | SPI Data Out
4 | 9 | SS | O | SPI Chip Select
5 | - | - | - | No connection

The XLRs are wired conventionally, i.e. Pin 2: hot, pin 3: cold, pin 1: signal ground. However, since all XLRs carry AES3/11 signals the reversal of the hot and cold pins will not affect operation since these interfaces are phase-insensitive.

VSIO Adapter hardware layout VSIO


Architecture

The figure below shows a simplified block diagram of the VSIO Adapter. For full details of the available settings for the VSIO Adapter, refer to the section covering the VSIO Adapter Control dialogue box.

The VSIO Adapter comprises three main sections. All of these are controlled via dS-NET, but in other respects their operation is almost entirely independent. This means that the three parts may be used together or in isolation.

The Generator section (at the bottom of the diagram) takes an AES3 audio input from the dScope's Signal Generator (from its XLR Digital Output) and transmits the audio data to the EUT as a serial multiplex.

The Analyzer section (above the Generator) takes serial audio multiplex data from the EUT and converts it to AES3 for transmission to the dScope's Signal Analyzer, through its XLR Digital Input.

The Control section (top left) is a serial controller for the EUT, which allows the user to send control data and monitor status returns in either I2C or SPI format.

Generator

Synchronisation

The Generator section of the VSIO Adapter can be synchronised to any one of three selectable sources:

Sync Source
Note
dScope DO
· SCK/LRCK output to EUT;
· MCK output to EUT or undriven;
· dScope DO can use local / any Ref Sync.
EUT
(GEN-SCK/LRCK)
· SCK/LRCK input from EUT (as sync);
· MCK output to EUT or undriven;
· dScope DO must use VSIO Ref Sync.
EUT
(GEN-MCK)
· SCK/LRCK output to EUT;
· MCK input from EUT (as sync);
· dScope DO must use VSIO Ref Sync.

When the dScope Digital Output is selected as sync source, the VSIO Adapter Generator path timing is recovered from the AES3 data received by the VSIO. SCK and LRCK are driven out of the VSIO into the EUT, along with the serial audio data. The dScope's DO should use local or other Ref Sync, but should not be synchronised to the VSIO's Ref Sync output (although it can be referenced to DI from the Analyzer section if that is referenced from the EUT). The VSIO can drive an MCK into the EUT if required.

When the EUT's SCK/LRCK are selected as sync source, these pins are configured as inputs from which all Generator section timing is derived. Serial audio data is clocked out in sync with the incoming SCK/LRCK. In this state, the dScope's DO must use the Ref Sync supplied by the VSIO, and must output the same sample rate. The VSIO can drive an MCK into the EUT if required.

When the EUT's MCK is selected as sync source, this pin is configured as an input from which all Generator section timing is derived. Serial audio data, SCK and LRCK are output in sync with the incoming MCK, with arbitrary LRCK phase. The sample rate is defined by the user-supplied MCK multiplier parameter. The dScope's DO must use the Ref Sync supplied by the VSIO, and must output the defined sample rate.

Signal path

If the VSIO Generator is disabled, AES3 data from the dScope's Digital Output is cascaded to a 'pass-through' port for use by an EUT AES3 input if required. Otherwise, it enters the VSIO where it is decoded by an AES3 receiver device, which extracts the audio data (and the synchronisation clocks in the case of the dScope being the sync source, as described above).

The audio data is formatted into one or more serial multiplexes, observing all the user's routing and formatting parameters, e.g. slot length, slots per wire, audio wordlength, MSB/LSB first etc. The serial audio multiplexes are clocked out to the EUT by the selected sync source.

Analyzer

Synchronisation

The Analyzer section of the VSIO Adapter can also be synchronised to any one of three selectable sources:

Sync Source
Note
dScope DO
· SCK/LRCK output to EUT;
· MCK output to EUT or undriven.
EUT
(ANA-SCK/LRCK)
· SCK/LRCK input from EUT (as sync);
· MCK output to EUT or undriven.
EUT
(ANA-MCK)
· SCK/LRCK output to EUT;
· MCK input from EUT (as sync).

When the dScope Digital Output is selected as sync source, the VSIO Adapter Analyzer path timing is recovered from the AES3 data received by the VSIO. SCK and LRCK are driven out of the VSIO into the EUT, and serial audio data from the EUT is synchronously clocked in. The VSIO can drive an MCK into the EUT if required. Note that the dScope DO can be locally or otherwise referenced, and can be referenced to the VSIO Generator section if that is synchronised from the EUT.

When the EUT's SCK/LRCK are selected as sync source, these pins are configured as inputs from which all Analyzer section timing is derived. Serial audio data is clocked into the VSIO by the incoming SCK/LRCK. The VSIO can drive an MCK into the EUT if required.

When the EUT's MCK is selected as sync source, this pin is configured as an input from which all Analyzer section timing is derived. SCK and LRCK are output in sync with the incoming MCK, with arbitrary LRCK phase, and serial audio data from the EUT is synchronously clocked in. The sample rate is defined by the user-supplied MCK multiplier parameter.

Signal path

If the VSIO Analyzer is disabled, AES3 data to the dScope's Digital Input is cascaded from a 'pass-through' port so that it can be provided by an EUT AES3 output if required. Otherwise, the dScope's DI is driven by an AES3-encoded output from the Analyzer section of the VSIO.

The audio data is derived from one or more serial multiplexes from the EUT, which is demultiplexed according to the user's routing and formatting parameters, e.g. slot length, slots per wire, audio wordlength, MSB/LSB first etc.

Control

The Control port can be set to operate in either SPI or I2C mode.

A control string of bytes (provided by the user either in a dialogue box or from a VB Script) is formatted accordingly and transmitted to the EUT. Any returned status is displayed or may be acted upon by a VB Script.

In the SPI mode, clock polarity and phase can be modified. In I2C mode, the data can be sent to any desired slave address, and the ACK/NACK status is returned.

Electrical

The Audio and Control ports can be independently set to operate at rail voltages of 1.8V, 2.5V, 3.3V or 5V. In the 5V case, input thresholds can be set to TTL or CMOS levels. Master on/off switching is provided to protect the VSIO Adapter and EUT during connection.

Output impedances are set to 100R, which is suitable for the cabling provided and most EUTs. 50R impedances can be jumper-selected for each individual output if required.

VSIO Adapter architecture VSIO


PCB jumper options

TO PREVENT SHOCK HAZARD, THE VSIO ADAPTER SHOULD ONLY BE OPENED BY QUALIFIED PERSONNEL. REMOVE THE POWER LEAD FROM THE VSIO ADAPTER BEFORE REMOVING THE TOP COVER.

A number of VSIO Adapter options are available through PCB jumpers. These are:

Setting the output impedance of the audio and control ports

Switching the dS–NET interface from RS–232 to RS–485

The top cover of the VSIO Adapter must be removed to access the PCB, which is shown in the diagram below. Jumpers should be removed, fitted or relocated using small snipe-nosed pliers. Removed jumpers should be carefully retained for future use.

The jumpers in the diagram are shown in the default positions.

Setting the output impedance of the audio and control ports

The output impedance of all audio and control port output pins default to 100R, but can be set to 50R if required. In normal circumstances, using the cables provided with the VSIO Adapter, there should be no need to alter the default 100R setting.

Generator outputs

Jumper | 100R (default) | 50R
LK5 (GEN-DATA1) | Away from dSub | Towards dSub
LK6 (GEN-DATA2) | Away from dSub | Towards dSub
LK7 (GEN-DATA3) | Away from dSub | Towards dSub
LK8 (GEN-DATA4) | Away from dSub | Towards dSub
LK9 (GEN-LRCK) | Away from dSub | Towards dSub
LK10 (GEN-SCK) | Away from dSub | Towards dSub
LK11 (GEN-MCK) | Away from dSub | Towards dSub

Analyzer outputs

Jumper | 100R (default) | 50R
LK15 (ANA-LRCK) | Away from dSub | Towards dSub
LK16 (ANA-SCK) | Away from dSub | Towards dSub
LK17 (ANA-MCK) | Away from dSub | Towards dSub

Control outputs

Jumper | 100R (default) | 50R
LK1 (CTL-DOUT) | Away from dSub | Towards dSub
LK2 (CTL-CS) | Away from dSub | Towards dSub
LK3 (CTL-CLK/SCL) | Away from dSub | Towards dSub
LK4 (CTL-DIN/SDA) | Away from dSub | Towards dSub

A FURTHER NOTE ABOUT CABLING AND TERMINATION IMPEDANCES: It is strongly recommended that the cable sets supplied with the VSIO Adapter (including the 1m twist'n'flat extensions) are used for connection to the EUT, especially in the case of the audio ports where correct data transaction can depend on good signal integrity. It is also recommended that 100R series source-termination resistors for all EUT clock or data OUTPUT pins are incorporated in the EUT PCB for optimum reliability (this applies to signals OUTPUT FROM THE EUT ONLY). If this cannot be done, it is usually possible to operate the audio interfaces successfully without them - if not, it is possible to modify the breakout cable (not the extension) to include 100R resistors in the appropriate lines within the shell of the 'D' connector. It is also possible to adjust the relative timing of serial clocks and data of the VSIO audio ports in certain configurations, as described in the VSIO Control dialogue box section.

Switching the dS–NET interface from RS-232 to RS-485

Although dS–NET is standardised on an RS–232 layer, it is also possible to operate it on an RS–485 instead, although for reasons of compatibility this is not recommended or supported.

Jumper | RS–232 (default) | RS–485
LK12 (all four jumpers) | Towards dSub | Away from dSub
LK14 (all four jumpers) | Towards dSub | Away from dSub
LK13 | Away from dSub | Towards dSub

Note that in RS–485 mode, different dS–NET cables must be used, and the last dS–NET peripheral must be fitted with a termination. For more details, see the About dS–NET section.

The dScope software has no knowledge of whether RS–232 or RS–485 mode is selected.

VSIO Adapter PCB jumper options VSIO


Fuses and ratings

TO PREVENT SHOCK HAZARD, THE VSIO SHOULD ONLY BE OPENED BY QUALIFIED PERSONNEL. REMOVE THE POWER LEAD FROM THE VSIO ADAPTER BEFORE REMOVING THE TOP COVER.

Fuse locations and ratings are as follows:

FUNCTION | LOCATION | TYPE
Mains | Mains inlet IEC block (external) | 1A(T) 20mm, CER
Power supply output | Main board, F1 (internal) | 1A(T) 20mm, GLS

Note that the locations of internal fuses are shown in the PCB diagram in the VSIO Adapter PCB jumper options section.

The VSIO Adapter's mains inlet is of the same type as the inlet of the dScope itself. For instructions on changing the mains voltage or fuse, see the Changing the mains voltage or fuse page in the Hardware section of the Operation Manual.

VSIO Adapter fuses and ratings VSIO


Specifications

Physical
Dimensions: 485x245x44mm (including rack mounting ears)
Weight: 2.2kg
Mains voltage: 90..125VAC/180..250VAC switchable
Power consumption: 15W
Operating temperature: 0 to 40ºC, max 85% relative humidity

Audio ports (Generator and Analyzer)

NOTE: Generator and Analyzer settings are independent
NOTE: All clock and data signals are subject to a 24.576MHz maximum rate

Data Format:
Slots (channels) per frame (sample period):
16 on one wire
8 on each of two wires
4 or 2 on each of four wires
Slot length: 8, 16, 24 or 32 bits
Audio wordlength: 8..24 bits
Audio alignment: any position in slot, optional sign extension
Orientation: MSB or LSB first

Routing:
Output slots: all routable from Generator A or B channel, or OFF
Input slots: any two routable to Analyzer A or B channel

Clocking:
Sample rates: 32, 44.1, 48, 88.2, 96, 176.4 or 192kHz
Sync source: dScope, EUT(SCK/LRCK) or EUT(MCK)
SCK and LRCK: input or output, programmable polarities
LRCK format: wordclock/one-bit, early/normal
MCK: input, output or OFF, rate: 64, 128, 192, 256, 384 or 512fs

Rail Voltage:
1.8V, 2.5V, 3.3V, 5V (TTL or CMOS threshold)

Control port

Bit rate:
I2C mode: 86.4kbps
SPI mode: 86.4kbps

Rail Voltage:
1.8V, 2.5V, 3.3V, 5V (TTL or CMOS threshold)
Note: I2C pins have 3k3 pull-up resistors fitted internally

Maximum ratings (audio and control ports)

NOTE: These ratings are those beyond which device damage may occur. Correct operation of the VSIO Adapter is not implied over the entire range of these limits.

Maximum voltage applied to input pins: -0.5V to selected rail voltage + 0.5V
Minimum load applied to output pins: 0R indefinitely
Maximum forced current at output pins: 10mA

VSIO Adapter specifications VSIO


Other peripherals

The dScope Series III family also includes 'dumb' peripherals which do not need to be controlled via dS-NET.

Currently, the only such peripheral available is the Passive Low-pass Filter.

Other peripherals


Passive Low-pass Filter

This section describes the capabilities and operation of the Passive Low-pass Filter. For details of the layout of the unit and connector pinouts, see the Passive Low-pass Filter hardware layout section.

Overview

The Passive Low-pass Filter is intended to aid measurement of switching ('Class D', or 'PWM') power amplifiers where the presence of shaped and switching noise outside the audio band can adversely affect operation of the Analogue Inputs of the dScope or other audio analyzer.

Connections

The Passive Low-pass Filter is connected between the loaded amplifier and the dScope's Analogue Inputs, via XLR connectors. Note that excessive cable capacitance between the Passive Low-pass Filter and the dScope can impair the flatness of the filter's pass-band, so short cables should be used. A suitable pair of short XLR cables is provided with the unit.

NOTE: The Passive Low-pass Filter is NOT intended to be connected between the power amplifier and the load. To do so, or to connect any low impedance to the output of the Passive Low-pass Filter whilst it is driven from a power amplifier will result in permanent damage to the unit.

Passive Low-pass Filter Other peripherals


Hardware layout

THIS SECTION TO BE COMPLETED

The Passive Low-pass Filter has two channels, with XLR input and output connectors accessed from the front panel. The XLRs are wired conventionally, i.e. Pin 2: hot, pin 3: cold, pin 1: signal ground.

The unit requires no power, and no connections are made on the rear panel.

The Passive Low-pass Filter is supplied with removable 19" racking ears, which may be removed for table-top operation. For table-top operation, it is fitted with removable plastic feet which may be removed for rack operation.

Passive Low-pass Filter hardware layout Passive Low-pass Filter


PCB jumper options

THIS SECTION TO BE COMPLETED

Passive Low-pass Filter PCB jumper options Passive Low-pass Filter


Specifications

THIS SECTION TO BE COMPLETED

Physical
Dimensions: 485x245x44mm (including rack mounting ears)
Weight: 1.5kg
Operating temperature: 0 to 40ºC, max 85% relative humidity

Response
Insertion loss: <0.05dB (240R per leg, assumed to be feeding 100kR dScope input)
Flatness: <+/-0.05dB 20Hz..20kHz wrt 1kHz
Roll-off: 35dB attenuation at 91kHz (typical)
Channel-to-channel cross-talk: <–140dB, 20Hz to 15kHz

Maximum ratings
Maximum voltage (leg-to-leg, or either leg to signal ground, 1kHz): 300VAC
Maximum voltage (leg-to-leg, wideband): 160VAC
Maximum current (per leg): 30mA
Note that stresses beyond the maximum ratings may cause permanent damage to the unit.

Passive Low-pass Filter specifications Passive Low-pass Filter